Tags: dvips, installed, kde, latex, programming, run, suse, tex, unfortunately, working, xdvi

LaTeX under Suse 10.1 - won't work

On Programmer » Tex

4,012 words with 3 Comments; publish: Wed, 07 May 2008 16:36:00 GMT; (20046.88, « »)

Hello, I recently installed Suse 10.1 with KDE. Unfortunately, I can't

get LaTeX working AT ALL. I can run xdvi, dvips etc, but not the latex

files themselves. I installed teTex as suplementary software.

I've tried searching for latex-similar files and linking them, but this

gives me the following error message, and leads me to believe that the

necessary software isn't on the OS at all.

latex Thesis.tex

This is TeX, Version 3.141592 (Web2C 7.5.4)

kpathsea: Running mktexfmt latex.fmt

fmtutil: format `latex' not available.

I can't find the format file `latex.fmt'!

I tried using the software updater in Yast, but there's no latex in the

index.

I'm a reletively new user and would appreciate any help you can give to

get Latex (and bibtex) running properly.

All Comments

Leave a comment...

  • 3 Comments
    • hercat wrote:

      > Hello, I recently installed Suse 10.1 with KDE. Unfortunately, I can't

      > get LaTeX working AT ALL. I can run xdvi, dvips etc, but not the latex

      > files themselves. I installed teTex as suplementary software.

      > I've tried searching for latex-similar files and linking them, but this

      > gives me the following error message, and leads me to believe that the

      > necessary software isn't on the OS at all.

      > latex Thesis.tex

      > This is TeX, Version 3.141592 (Web2C 7.5.4)

      > kpathsea: Running mktexfmt latex.fmt

      > fmtutil: format `latex' not available.

      > I can't find the format file `latex.fmt'!

      >

      > I tried using the software updater in Yast, but there's no latex in the

      > index.

      > I'm a reletively new user and would appreciate any help you can give to

      > get Latex (and bibtex) running properly.

      run

      fmtutil --all

      to create the format files.

      Herbert

      http://PSTricks.de/

      http://TeXnik.de/

      http://www.dante.de/CTAN/info/math/...de/Mathmode.pdf

      http://www.dante.de/faq/de-tex-faq/

      http://www.tex.ac.uk/cgi-bin/texfaq...ntroduction=yes

      #1; Wed, 07 May 2008 16:37:00 GMT
    • "hercat" <hercat.tex-program.todaysummary.com.hotmail.com> writes:

      > Hello, I recently installed Suse 10.1 with KDE. Unfortunately, I can't

      > get LaTeX working AT ALL. I can run xdvi, dvips etc, but not the latex

      > files themselves. I installed teTex as suplementary software.

      Which rpm(s) did you install? SuSE typically splits up teTeX in a tetex

      package and severl 'te_*' packages. You will at least need 'te_latex'.

      > I've tried searching for latex-similar files and linking them, but this

      > gives me the following error message, and leads me to believe that the

      > necessary software isn't on the OS at all.

      > latex Thesis.tex

      > This is TeX, Version 3.141592 (Web2C 7.5.4)

      > kpathsea: Running mktexfmt latex.fmt

      > fmtutil: format `latex' not available.

      > I can't find the format file `latex.fmt'!

      Did you create a link 'latex -> tex'? I would remove this link before

      installing te_latex. With teTeX 3.0 'latex' is actually a link to

      pdfetex (it still produces DVI files).

      cheerio

      ralf

      #2; Wed, 07 May 2008 16:38:00 GMT
    • Thanks very much to both of you. Removing the links and installing

      te_latex fixed the problem completely. I didn't do this before because

      the description was 'All about LaTeX', so I thought this was a manual

      of some type.

      I really appreciate the help.

      hercat

      #3; Wed, 07 May 2008 16:39:00 GMT